Snippets code from my daily experience

May 5, 2008

GIMP doesn’t reuse running instance under Windows

Filed under: gimp,gimp-remote,gimp-win-remote,viewsourcewith — dafi @ 7:44 pm

A ViewSourceWith‘s user posted an interesting question on forum: how to reuse an already running GIMP instance.

I’ve never incurred on this problem on my Linux box so I was very surprised.

Booting under Windows I’ve found this different behavior, very strange because the GIMP documentation explains how to obtain the opposite effect using command line switches, i.e. running always new instances.

IMHO the reuse technique under Windows is bugged so I found a workaround using the not so famous gimp-win-remote executable program present on bin directory.

gimp-win-remote checks (correctly) if GIMP is already running and reuse it.

I’m curious to know if Mac OS/X complains to unix world, if you have a Mac and would satisfy my curiosity I will update the ViewSourceWith FAQ pagešŸ˜‰

3 Comments

  1. I’m running Windows Vista Home Basic, Gimp 2.4.6, and gimp-win-remote 3.0.0.

    I can’t get gimp-win-remote to work. Every time I open an image, a new instance of The Gimp starts.

    I’ve posted about this issue in a few places. No one has a solution; I’ve yet to meet anyone with Vista who uses The Gimp so I’m not sure if I’m the only one with the problem.

    Comment by Brian Black — June 25, 2008 @ 8:22 pm

  2. I’VE THS PROBLEM TOO

    Comment by pIERPA — November 14, 2008 @ 8:02 pm

  3. I downloaded the open software, GIMP. http://ftp.gimp.org. The images are recognizing it but apparently the computer doesn’t know where Gimp is or that it is software. I get the error, \JimsPictures\P6160012.JPG is not a valid Win32 application.
    GIMP is apparently in the C:\Program Files\GIMP-2.0\bin gimp-2.6.exe file.

    Is there an answer? Windows XP is my OS.

    Comment by Jim Stiles — May 5, 2009 @ 9:52 pm


RSS feed for comments on this post.

Blog at WordPress.com.

%d bloggers like this: